{"support":{"yesButton":"Yes","noButton":"No","feedback":{"title":"What can we do to improve?"},"submitButton":"Submit","successMessage":"Thank you for your feedback","title":"Was this helpful?","feedbackPercentLabel":"of people found this helpful","captcha":{"error":"Please check the box"}}}
Search FAQs
{"searchBar":{"inputPlaceholder":"Search by keyword or ask a question","searchBtn":"Search","error":"Please enter a keyword to search"}}
Why are all LED's flashing simultaneously on my Smart-UPS SU, SUA, or SURT model?
Issue:
LED's flashing simultaneously
Product Line:
Smart-UPS
Environment:
All non-LCD display models (Line Interactive and Online), All Serial Numbers
Cause:
All LED's, or the two center columns of LED's flashing simultaneously generally indicates a hardware failure.
Resolution:
Try to reset the fault by turning the UPS off/on or by performing a "brain dead" on the unit. To perform a "brain dead":
- Turn off the UPS
- Unplug the UPS from utility power
- Press and hold the off button again - You will hear a "click" and may see a brief flash of the LED's
Can't find what you are looking for?
Reach out to our Customer Care team to receive information on technical support, assistance for complaints and more.