{}

Our Brands

Search FAQs

Video: Connect Battery on Back-UPS RS/NS M2 & MS Series

Issue:
Tutorial for connecting or replacing the internal battery on Back-UPS Pro RS/NS M2 & MS series. The UPS will indicate a disconnected battery by flashing an empty battery icon on its front display.

Product Line:
Back-UPS Pro RS/NS

Environment:
BR1000MS/BR1350MS/BR1500MS
BN1100M2/BN1350M2/BN1375M2/BN1500M2

Cause:
All APC UPS systems are shipped with batteries disconnected to comply with US DOT regulations. The UPS will flash the battery icon to indicate a disconnected battery state.
A severely discharged/damaged battery will also generate the flashing battery alert. The Back-UPS will not be able to recharge or otherwise use a severely discharged battery.

Resolution:
To connect, disconnect or replace the internal battery, please follow the steps indicated in the video and images below.



APC Canada

Attachment(s)

BR1500MS battery connection.jpgBR1500MS battery connection.jpg [175.7 KB]
Explore more
Range:
Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.
Explore more
Range: