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Why is the Environment Tab missing from the web interface on my AP9631 NMC2 v5.X.X firmware?
Why is the Environment Tab missing from the web interface on my AP9631 NMC2 v5.X.X firmware?
Product Line
- UPS Network Management Card 2 (NMC2) - AP9631/31CH
Environment
- All serial numbers
- v5.X.X
Cause
Historically, on AP9618/19, the "Environment Tab" in the web interface has shown regardless if a probe was attached or not and regardless of NMC->Device communication. This behavior was modified in earlier revisions of AP9631 firmware and did not align with user expectations.
Resolution
For sumx and sy, versions 5.1.7 the Environmental Tab behavior has changed. Whether or not the conditions below are true, your Environmental Tab in the web user interface (UI) and Environmental configuration section in other interfaces should always be present whether or not:
- you have the correct NMC firmware application loaded, or
- you have an environmental accessory attached.
As long as the AOS is loaded properly and you have an AP9631 or AP9631 embedded product with v5.1.7 sumx or sy APPs, the information will be visible and and indicate whether or not it detects a sensor connected. If a sensor is physically connected but indicates that no sensor is detected, please proceed with the steps below to verify a few items.
The Environment Tab/options can disappear from Web UI or Command Line Interface of your AP9631 or AP9631 based product for one or more of the following reasons:
- The firmware application is incorrect for the product that the AP9631 is installed in. Please ensure that you are using the most up to date application for your device.
- Smart UPS and Matrix UPS - sumx APP
- Symmetra 3 phase - sy3p APP
- Symmetra single phase - sy APP
- Rack PDU 2G - rpdu2g APP
- Your firmware is correct and up to date but you do not have any environmental accessories connected to the AP9631 or AP9631 based device.
- Ensure that at least (1) but up to (2) of your environmental accessories are connected to the AP9631 so that the Envioronment options will appear (both in the web UI or Command Line Interface)
- Compatible environmental accessories include but are not limited to:
- AP9335T Temperature Probe
- AP9335TH Temperature and Humidity Probe
- AP9810 Dry Contacts I/O Accessory Dongle
- You have verified you do have an AP9631 or AP9631 embedded device then referenced #1 and #2 mentioned above and still do not see an environmental tab. Some additional steps include:
- Try to reboot the NMC by issuing a Reboot Management Interface command via the web UI or via the command line interface.
- Try to reseat the NMC in its smartslot. Note: Reference your UPS or other device's user guide on the proper procedure for doing this.
- If the issue persists, please download the event, data, and config files from the NMC via FTP or SCP and contact APC support.
Note: If you plug in any environmental accessory and later disconnect it, the environment tab/options will be available until the next reboot. The interface will indicate a lost communication state with the device you removed until the aforementioned reboot.
This behavior is different from the earlier NMC1 based devices like AP9618 or AP9619.