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Video: How do I configure APC Network Management Card network settings?

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Issue
An APC Network Management Card must be configured with network settings before it can communicate on the network. Once the cards have been configured with an IP address, Subnet Mask, and Default Gateway the cards can be accessed, managed, and controlled from other computers on the network. There are multiple configuration options available, outlined below, for each family of Network Management Cards or devices that have embedded versions of these products.

Product Line
  • Web/SNMP Card - AP9606
Devices with an embedded Web/SNMP Card include (but are not limited to): Environmental Monitoring Unit 1 (AP9312TH)
  • Network Management Card 1 (NMC1) - AP9617, AP9618, AP9619
Devices with an embedded Network Management Card 1 include (but are not limited to): Metered/Switched Rack PDUs (AP78XX, AP79XX), Rack Automatic Transfer Switches (AP77XX, Environmental Monitoring Units (AP9320, AP9340, NetBotz 200)
  • Network Management Card 2 (NMC2) - AP9630/AP9630CH, AP9631/AP9631CH, AP9635/AP9635CH
Devices with an embedded Network Management Card 2 include (but are not limited to): Early model 2G Metered/Switched Rack PDUs (AP84XX, AP86XX, AP88XX, AP89XX), Rack Automatic Transfer Switches (AP44XX), Certain Audio/Video Network Management Enabled products, Early model Smart-UPS Online (SRT).
  • Network Management Card 3 (NMC3) - AP9640, AP9641, AP9544
Devices with an embedded Network Management Card 3 include (but are not limited to): Metered/Switched Rack PDUs (AP84XX, AP86XX, AP88XX, AP89XX, APDU9), Rack Automatic Transfer Switches (AP44XXA), Smart-UPS Online (SRT).

Environment
  • All serial numbers
  • All firmware revisions (unless otherwise noted)
  • Unconfigured Network Management Card-enabled devices
  • Network Management Card devices requiring reconfiguration

Cause
A Network Management Card requires TCP/IP settings prior to being accessible via a network.


Resolution
Network Management Card 1:

In regards to Network Management Card 1 (AP9617, AP9618, AP9619) or devices with an embedded Network Management Card 1 (such as a AP78XX or AP79XX Rack PDU, Environmental Monitoring Unit, etc), there are three available options to configure the Network Management Card (NMC) with it's initial settings: the Wizard, terminal emulation (local/direct connection), and Address Resolution Protocol (ARP).

Default boot mode: DHCP/BootP - With DHCP Option 43 Vendor Cookie required to accept DHCP Offer.

By default, all of APC's Network Management Card 1 based devices are configured for a boot mode of DHCP/BOOTP. If using DHCP, a vendor cookie (DHCP Option 43) is required by default. If it is not configured on your DHCP server, the card will not accept an IP address. You can use the methods below to configure/access the card if you do not wish to use DHCP/BOOTP. Please see APC KB article FA156110 for more information on DHCP options.

Network Management Card 2/3

Default boot mode: DHCP Only - With DHCP Option 43 Vendor Cookie NOT required to accept DHCP Offer.

By default, all of APC's Network Management Card 2 and 3 based devices (such as an AP8XXX Next Gen Rack PDU (NMC2 only)) with AOS 5.1.1 or higher, are configured for DHCP Only with no vendor cookie required by default. They will obtain an IP address automatically so you may need to refer to your DHCP server to find out what IP address it obtained. Please see APC KB article FA156110 for more information on DHCP options.

All APC devices have a MAC address that begin with 00 C0 B7 which may help while reviewing your DHCP Client List.

In order to configure your Network Management Card-enabled device, select one of the available configuration methods listed below:
Configuration Option 1 - Device IP Configuration Wizard

The Device IP Configuration Wizard is a Windows application designed specifically to remotely configure the basic TCP/IP settings of Network Management Cards. The Wizard is included on the CD bundled with the cards, and available to download from the APC website. This utility supports NMC1/NMC2 cards that have firmware version 3.x.x or higher.

Please keep in mind that with certain firmware releases, the NMC can obtain a DHCP address and also prevent the wizard from working correctly. You may want to check your DHCP client list for any MAC addresses beginning with 00 C0 B7, which indicates an APC address. In addition, check the card you are trying to configure. Any card with valid IP settings will have a solid green status LED.

If using the wizard over the network, please note, the previously unconfigured NMC must be on the same subnet as the computer running the wizard. An alternative method to using the wizard via the network method may be to use a direct network connection between a computer and the NMC you are trying to configure and running the wizard. Ultimately, your computer and the NMC will be on a peer to peer network which will allow for configuration as well.

NOTE: This wizard will also not work with any Network Management Card family if the NMC was previously configured and not in DHCP or BOOTP boot mode. v5.0.0 and higher of the wizard, available from apc.com, allows you to locate unconfigured cards or locate configured cards on the network by IP range.

NOTE: The Device IP Configuration Wizard is not able to assign the IP address, subnet mask and default gateway settings of Network Management Cards running AOS 6.5.0 and 6.5.2. This is a known issue and has been resolved with AOS 6.5.6.

NOTE: In NMC2 firmware version 6.8.0 and higher, and in NMC3, you cannot search for assigned devices already on the network using an IP range unless you enable SNMPv1 and set the Community Name to “public”.
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Configuration Option 2 - Terminal Emulation (local/direct connection)

Terminal Emulation is a built-in function on most operating systems (ex: HyperTerminal). Before using any terminal emulation program, any services using the COM ports must be stopped. For example, if you are running a serial version of APC's PowerChute software, the APC UPS service must be stopped prior to running the terminal program. Then, follow these instructions:

NOTE:If you have the scroll lock on, HyperTerminal will not communicate properly with an APC UPS or accessory.
Connect to the UPS/device serial port using the correct APC configuration cable. Part numbers are below for common devices. Please refer to the User Guide if you are not sure or your device is not listed.

!WARNING! - Connecting a non-APC serial cable to your device can cause unwanted, erratic device behavior.
Device Configuration Cable Part Number
Most UPS devices with a DB-9 serial port940-0024 or 940-1524 (DB-9 to DB-9)
Rack PDU (AP78XX, AP79XX, AP84XX**,AP86XX**, AP88XX**, AP89XX**)940-0144 (RJ-12 to DB-9)
1st Generation Rack Automatic Transfer Switch (AP7750 only)940-1000 (DB-9 to DB-9)
2nd Generation Rack Automatic Transfer Switch (AP77XX, excludes AP7750)940-0144 (RJ-12 to DB-9)
4th Generation Rack Automatic Transfer Switch (AP44XX**)940-0144 (RJ-12 to DB-9)
NetBotz 200/Environmental Monitoring (AP9319, AP9340, AP9320)940-0103 (DB-9 to DB-9)
Rack Air Removal Unit (ACF400, ACF402)940-0103 (DB-9 to DB-9)

**This device is NMC2 based so proceed to NMC2/NMC configuration instructions.


After connecting the correct cable, start the terminal emulation program of your choice. Configure port settings appropriately for the device you are attached to (refer to the User Guide for the particular device). Commonly used port settings are as follows:
Device COM Port Settings
Most UPS devices with a DB9 serial port2400 bps, 8 data bits, no parity, 1 stop bit, and no flow control.
Rack PDU9600 bps, 8 data bits, no parity, 1 stop bit, and no flow control.
1st Generation Rack Automatic Transfer Switch (AP7750)19,200 bps, 8 data bits, no parity, 1 stop bit, and no flow control for initial configuration, 2400 bps for NMC configuration - refer to user's manual for more information
2nd Generation Rack Automatic Transfer Switch (AP77XX, excludes AP7750)9600 bps, 8 data bits, no parity, 1 stop bit, and no flow control
NetBotz 200/Environmental Monitoring (AP9319, AP9340, AP9320)9600 bps, 8 data bits, no parity, 1 stop bit, and no flow control.
Rack Air Removal Unit9600 bps, 8 data bits, no parity, 1 stop bit, and no flow control.
  • Apply the port settings to establish the connection.
  • Press <Enter> 3-5 times to display the username prompt.*
  • Use the default username and password of "apc".
You are now in the control console.
  • Choose "Network"
  • Choose "TCP/IP"
  • Choose "Boot mode"
  • Change Boot mode to "Manual"
  • Set the system IP, subnet mask, and default gateway.
  • Accept changes.
  • Press Ctrl-C to return to main menu.
  • Log out of console to save changes.
Now, you can remotely log into the NMC using web access or Telnet.

NOTE:*Does not apply to 1st Generation Rack Automatic Transfer Switches for "out of the box" configuration. Refer to User Guide.

Network Management Card 2 (AP9630, AP9631), Network Management Card 3 (AP9640, 19641)and related accessories require different configuration settings in order to be configured locally.

To connect to a NMC2, you must use the 940-0299 Tip, Ring Sleeve (TRS) to DB9 cable and connect it directly to the NMC2 into the 2.5mm jack labeled "console" rather than the UPS serial port. To connect to a NMC3, use the provided 960-0603 micro-USB cable.
  • Within a UPS, the NMC2 devices communicate with the following port settings:
9600 bps, 8 data bits, no parity, 1 stop bit, and no flow control.
  • Apply the port settings to establish the connection.
  • Press enter 3-5 times to display the username prompt.
  • Use the default username and password of "apc".
You are now in the command line control console.
  • Type help or ? to display all available commands.
  • Use the tcpip command to configure manual network settings to assign manual IP settings. The tcpip command automatically changes your boot mode to manual once you submit it. It is necessary to issue a reboot command immediately after assigning your manual settings. Text in italics indicates a variable. For each variable, type a numeric value that has the format xxx.xxx.xxx.xxx.
apc> tcpip -i yourIPaddress -s yourSubnetMask -g yourDefaultGateway
apc> reboot

Example:
apc> tcpip -i 159.216.45.39 -s 255.255.254.0 -g 159.216.45.1
apc> reboot


Use the boot command to change the Network Management Card's boot mode ONLY if you are using DHCP or BootP.

Usage: boot -- Configuration Options
boot [-b dhcpBootp* | dhcp | bootp | manual>] (Boot Mode)
[-a remainDhcpBootp | gotoDhcpOrBootp>] (After IP Assignment)
[-o stop | prevSettings>] (On Retry Fail)
[-c enable | disable>] (Require DHCP Cookie)
[-s retry then stop #>] (Note: 0 = never)*
[-f retry then fail #>] (Note: 0 = never)*
[-v vendor class>]
[-i client id>]
[-u user class>]

*DHCP/BootP and retry options are only available in NMC2 AOS 5.0.X. It is no longer an option in AOS versions > 5.0.X
For a video representation of NMC2 configuration via terminal emulation, refer to the video below:



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Configuration Option 3 - ARP (Address Resolution Protocol)
Address resolution protocol (ARP) can also be used to configure the NMC. The MAC Address of the NMC is needed for this method of configuration. The MAC address is located on the quality assurance slip that shipped with the NMC, and is also located on a white sticker on the NMC itself. From a computer on the same subnet as the unconfigured NMC, follow these instructions:
  • Open a command prompt or terminal window and type the following (replacing <IP address> and <MAC Address> with actual values):
    NOTE:On Windows operating systems, you may need to run the command prompt as Administrator in order to use the arp command. To do this, right click on the Command Prompt shortcut and select "Run as Administrator."
arp<space>-s<space><IP address><space><MAC Address>
You must use the following format for the MAC Address: xx-xx-xx-xx-xx-xx
  • On Mac OS X specifically: sudo<space>arp<space>-s<space><IP address><space><MAC Address>
  • Next, use Ping with a size of 113 bytes to assign the IP address defined by the ARP command.

For the IP address defined in the first step, use one of the following:
  • Windows command format: ping<space><IP address><space>-l<space>113
    • The -l option is the letter L but must be lowercase when executing the command, as noted above.
  • Linux command format: ping<space><IP address><space>-s<space>113
  • Mac OS X command format: ping<space>-s<space>113<space><IP address>
  • Now, you can Telnet to the card by typing: telnet <IP address>
  • Use "apc" for username and password.
  • Configure/apply any additional changes based on the instructions above or in the user's manual.
  • Log out to save changes.
NOTE: Users will be unable to configure the IP address setting by using ARP on the network management cards running AOS 6.5.0 and 6.5.2. This is a known issue and has been resolved with AOS 6.5.6.
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Configuration Option 4 - DHCP Option 12 (NMC2 devices, AOS 5.1.5 or higher only)
Beginning with the AOS 5.1.5 release, the NMC2 has implemented Option 12 (Host Name) as part of the DHCP request. DHCP option 12 uses the devices' host name. As of AOS 5.1.5, the default NMC host name will be apcXXYYZZ, where XXYYZZ represents the last six characters of the MAC Address (enclosed on a slip with the shipped product) of the NMC. It is also available on a sticker on the NMC2 itself.

If your network is setup correctly (described below), you will be able to access "unconfigured" / just-out-of-the-box NMCs by referencing the NMC as follows:

1.At a terminal (or DOS) prompt, ping the NMC using ping apcXXYYZZ

2. In a web browser, access the NMC web interface using http://apcXXYYZZ

NOTE:Tests have shown that even with the network properly configured, the ability to reference devices that support this option is not immediate. In APC tests, it took between 6 and 16 minutes before this functionality worked. However, it worked every time (max wait 16 minutes).  Depending on your network setup, your experience may differ.

Network Setup:
In order for option 12 to work properly, the network segment must be configured with the "Dynamically update DNS A and PTR records for DHCP clients that do not request updates ..." (or equivalent) box selected.

See below, as an example:
Image
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Configuration Method 5 - via Smart-UPS front panel LCD - (Supported SMT, SMX, and SRT* Models with UPS NMC2/NMC3)

*NOTE: This method can be used to configure the embedded UPS NMC2 or optional secondary NMC2 for SRT models.

Some newer Smart-UPS models provide the capability to configure the Network Management Card 2/3 (NMC2/NMC3) IP address, subnet mask, and gateway using the front panel LCD display menu. Before proceeding, ensure your NMC2/NMC3 is installed in the UPS SmartSlot and is powered, indicated by the status LED on the NMC2/NMC3.

Your UPS display will look similar to one of the following types shown below. Press ESC to bring up the Menu, if not already displayed.
SmartUPS display

In order to access the NMC2NMC3 configuration functionality through the UPS LCD, the LCD menu must be put into Advanced Mode. This is accomplished by going into the Configuration menu and changing the Menu Type from Standard to Advanced on the UPS's LCD menu. Upon changing this menu setting, you will be able to configure the UPS NMC2/NMC3 by going back into the Configuration menu.

NMC2/NMC3 boot mode options available in Configuration Menu:
  • DHCP
  • DHCP & BOOTP
  • Manual

If you choose Manual mode, enter the IP address, subnet mask, and default gateway. DHCP (the NMC2 default AOS v5.1.1 and higher) and DHCP & BOOTP models will not require any further configuration beyond accepting the setting. After you've finished, the Network Management Card will reboot within ~1 minute after settings are applied, and the current IP settings will be displayed under the UPS LCD's About menu.

NOTE: If your UPS LCD menu doesn't have the Configure NMC: option after putting the UPS LCD menu in Advanced mode, you may have one or more of the following happening:
  • The NMC2/NMC3 is not being recognized by the UPS/UPS SmartSlot.
  • The UPS firmware doesn't support this functionality
Consult the user's guide that came with the UPS or contact your local Technical Support team with any concerns.

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