{}

Our Brands

Search FAQs

PowerChute Business Edition version 10.x fails to install on VMware vMA with error "System Locale is set to C"

Issue:
PowerChute Business Edition fails to install on VMware vMA with error "System Locale is set to C. Please reset System Locale"



Product:
PowerChute Business Edition 10.x

Environment:
VMware vMA  versions 6.0, 6.5

Cause:
Profile set to the wrong locale.

Solution:
Change the locale of the profile.

Open the profile file using the following command: sudo vi /etc/profile

Add one of the following to the end of the profile file:

#English
export LC_ALL=en_US.utf8
export LANG=en_US.utf8
export LANGUAGE=en_US.utf8

#Chinese
export LC_ALL=zh_CN.utf8
export LANG=zh_CN.utf8
export LANGUAGE=zh_CN.utf8

#Japanese
export LC_ALL=ja_JP.utf8

export LANG=ja_JP.utf8
export LANGUAGE=ja_JP.utf8

Remove any lines in the profile file that contain “export LANG=C.utf8”.

Reboot the vMA

Confirm that the system locale has changed by entering the command: Locale

NOTE: If you are not familiar with using vi editor you can copy the file to a Windows system and edit the file with a text editor. Then copy the file back. Prior to coping the file you should make a copy of the file. The command is sudo cp /etc/profile /etc/profile.saved. Once saved you will need to change the file permissions to allow write access. The command is sudo chmod +w /etc/profile.

APC Saudi Arabia

Explore more
Explore more
Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.