{}

Our Brands

Search FAQs

Data Center Expert | Lost communication to APC devices using SNMPv3 communication when upgrading NMC AOS to v6.4.6

Issue:
SNMPv3 communication between StruxureWare Data Center Expert (DCE) and APC Network Management Cards (NMC) may be lost when upgrading the NMC to version 6.4.6 while it is currently being monitored within DCE.

Product Line
StruxureWare Data Center Expert (DCE)
- Basic Appliance (AP9465)
- Standard Appliance (AP9470)
- Enterprise Appliance (AP9475)
- Virtual Appliance (AP94VMACT)
StruxureWare Central (SWC)
InfraStruXure Central (ISXC)

Environment:
StruxureWare Data Center Expert (all versions)
Network Management Cards being upgrading to AOS version 6.4.6 which are also monitored by SNMPv3

Cause:
Upgrading an APC device that is already monitored using SNMPv3 within DCE to AOS version 6.4.6 causes a lost communication between DCE and the NMC. This issue is caused by a problem with the SNMP v3 communication process on the NMC AOS.

Other notes:
  • Devices monitored in DCE using SNMPv1 are not affected.
  • Devices being added to a DCE server for the first time which have AOS 6.4.6 loaded are not affected.
  • Devices with AOS v6.4.6 loaded that are being re-added to a DCE server will show as a generic SNMP device. This situation requires the resolution below.

Resolution:

Update: This issue is fixed in NMC AOS v6.5.0 and higher. This AOS has been bundled and released with most firmware applications within Q3/Q4 of 2017. No additional future steps will be required by the user to prevent further SNMPv3 communication loss during the next NMC firmware upgrade.

To re-establish SNMPv3 communication, it is recommended to reboot your DCE server under the file menu within the desktop client. Alternatively, you may downgrade the NMC firmware version if rebooting the DCE server is not an option.

If for some reason, such as to apply a configuration change, the NMC running AOS v6.4.6 is rebooted or a warmstart/network interface restart occurs, SNMPv3 communications will be lost and will again require the reboot of the DCE server.

Other SNMPv3 monitoring tools may require similar action in order to restore SNMPv3 communication with an NMC with AOS v6.4.6. For this reason, SNMPv3 users may not want to apply any firmware upgrades containing AOS 6.4.6 and wait until the next version for the particular application is available.


NOTE: If you are on a version of Data Center Expert prior to 7.4.2, you will need to update a device definition file for APC devices.  For details see knowledge base Data Center Expert | Application Version does not update in the UI after upgrading devices to AOS 6.4.6 and newer .

APC Philippines

Explore more
Explore more
Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.