Browse FAQs

Which Silcon Triple Chassis firmware revision is required for the AP9622 to communicate with the Silcon?

Published date: 04 June 2019


The Silcon Triple Chassis needs to be Rev 12 or higher in order to work with the AP9622 card. If you have an earlier revision of the Silcon Triple chassis, you will lose functionality on the AP9622.

Contact APC 3-Phase Power Technical Support for information on resolving this issue.
 

Was this helpful?

What can we do to improve the information ?

Can't find what you are looking for?

Reach out to our customer care team to receive information on technical support, assistance for complaints and more.