Issue:
"Please check that the USB cable between your battery backup and PC is properly connected" or "Unknown Device"
Product Line:
BACK-UPS ES, BACK-UPS CS, BACK-UPS USB, BACK-UPS PRO, BACK-UPS NS, BACK-UPS XS, BACK-UPS RS
Environment:
This problem may occur with the following APC Battery Back-UPS:
BE350U, BE500U, BE725BB, BE450G, BE550G, BE650G1, BE750G, BP350UC, BP500UC, BP500CLR, BP700UC, BK350, BK500,
BX1000x, BX1500x, BR1000x or BR1500x.
Cause:
Windows 98/ME: hidclass.sys, hidparse.sys, hidusb.sys
Windows 2000 or XP: hidclass.sys, hidparse.sys, hidusb.sys, hid.dll, pid.dll
Note: All of these drivers must be the same version. These drivers can be installed from your corresponding Windows CD.
Resolution:
1. Ensure that the USB communication cable is properly attached between the UPS and your PC.
2. Check to see if the UPS shows up as an Unknown Device in the Device Manager. (Start - Settings - Control Panel - System - Device Manager) Once in Device Manager click on the drop-down box to the left of Universal Serial Bus Controllers. Does Unknown Device show up here? If so, right click on this device and choose the uninstall option.
3. Disconnect the USB cable from your PC.
4. Shut down the PC.
5. Cycle power to the UPS by turning off and turning on the UPS. Note: Ensure the PC has completed shutting down prior to cycling power to the UPS.
6. Once the UPS has come back to the on-line mode of operation you can reboot your PC.
7. Once your PC has completely finished rebooting plug the USB cable back into your PC.
8. Ensure that your PC properly recognized the APC UPS correctly. To determine this access the Device Manager. Do you see listings as Batteries and Human Interface Device? If so, the PC did recognize the UPS correctly. If not, you'll need to ensure that the HID drivers are already installed. The operating systems and corresponding drivers are as follows:
9. If the USB cable is plugged into a USB hub try plugging the USB cable directly into the USB port on the PC itself.
10. If other USB devices are connected to the PC disconnect these devices before connecting the UPS USB cable and retry steps 1-8.
11. Reboot your PC. After reboot, did your PC recognize the UPS or are you still receiving the initial message of ""Please check that the USB cable between your battery backup and PC is properly connected""? If so, there are a few parameters of your PCs BIOS that need to be changed in order for your PC to recognize the USB device as an APC UPS after each boot. These changes are as follows:
Advanced Power Management Needs to be disabled
USB Legacy Device Needs to be enabled
Note: An APC representative cannot make changes or assist customers in making changes to the BIOS, as it is a liability to APC. The BIOS of your PC is both manufacturer and model specific. Consultation with the Original Equipment Manufacturer is advised in making these changes.
"Please check that the USB cable between your battery backup and PC is properly connected" or "Unknown Device"
Product Line:
BACK-UPS ES, BACK-UPS CS, BACK-UPS USB, BACK-UPS PRO, BACK-UPS NS, BACK-UPS XS, BACK-UPS RS
Environment:
This problem may occur with the following APC Battery Back-UPS:
BE350U, BE500U, BE725BB, BE450G, BE550G, BE650G1, BE750G, BP350UC, BP500UC, BP500CLR, BP700UC, BK350, BK500,
BX1000x, BX1500x, BR1000x or BR1500x.
Cause:
Windows 98/ME: hidclass.sys, hidparse.sys, hidusb.sys
Windows 2000 or XP: hidclass.sys, hidparse.sys, hidusb.sys, hid.dll, pid.dll
Note: All of these drivers must be the same version. These drivers can be installed from your corresponding Windows CD.
Resolution:
1. Ensure that the USB communication cable is properly attached between the UPS and your PC.
2. Check to see if the UPS shows up as an Unknown Device in the Device Manager. (Start - Settings - Control Panel - System - Device Manager) Once in Device Manager click on the drop-down box to the left of Universal Serial Bus Controllers. Does Unknown Device show up here? If so, right click on this device and choose the uninstall option.
3. Disconnect the USB cable from your PC.
4. Shut down the PC.
5. Cycle power to the UPS by turning off and turning on the UPS. Note: Ensure the PC has completed shutting down prior to cycling power to the UPS.
6. Once the UPS has come back to the on-line mode of operation you can reboot your PC.
7. Once your PC has completely finished rebooting plug the USB cable back into your PC.
8. Ensure that your PC properly recognized the APC UPS correctly. To determine this access the Device Manager. Do you see listings as Batteries and Human Interface Device? If so, the PC did recognize the UPS correctly. If not, you'll need to ensure that the HID drivers are already installed. The operating systems and corresponding drivers are as follows:
9. If the USB cable is plugged into a USB hub try plugging the USB cable directly into the USB port on the PC itself.
10. If other USB devices are connected to the PC disconnect these devices before connecting the UPS USB cable and retry steps 1-8.
11. Reboot your PC. After reboot, did your PC recognize the UPS or are you still receiving the initial message of ""Please check that the USB cable between your battery backup and PC is properly connected""? If so, there are a few parameters of your PCs BIOS that need to be changed in order for your PC to recognize the USB device as an APC UPS after each boot. These changes are as follows:
Advanced Power Management Needs to be disabled
USB Legacy Device Needs to be enabled
Note: An APC representative cannot make changes or assist customers in making changes to the BIOS, as it is a liability to APC. The BIOS of your PC is both manufacturer and model specific. Consultation with the Original Equipment Manufacturer is advised in making these changes.