{"searchBar":{"inputPlaceholder":"Search by keyword or ask a question","searchBtn":"Search","error":"Please enter a keyword to search"}}
{}

Our Brands

{"support":{"yesButton":"yes","noButton":"no","feedback":{"title":"What can we do to improve?"},"submitButton":"Submit","successMessage":"Thank you for your feedback","title":"Was this helpful?","feedbackPercentLabel":"of people found this helpful","captcha":{"error":"Please tick the box"}}}
Search FAQs

Replacing the Self-Signed SSL Certificate in PowerChute Business Edition versions 10.0.2 and above

Issue: 
How to replace the self-signed cert used by PowerChute Business Edition for HTTPS communication.

Product Line:
PowerChute Business Edition versions 10.0.2 and above

Environment:
All supported Windows and Linux operating systems. 

Cause:
Informational

Background:

PowerChute Business Edition is a web-based application accessible via a browser. By default PowerChute uses a self-signed SSL certificate for its Web Interface. Starting with PowerChute v10.0.2 it is possible to use your own certificate, for example one that has been signed by a Trusted Certificate Authority (CA), instead of the self-signed certificate.

Solution:
Please review the steps outlined in the attached PDF

For assistance with adding the self-signed certificate to a web browser see Schneider Electric FAQ FA165288 How to install the PowerChute Business Edition Agent “self-signed” security certificate to a browser.

Can't find what you are looking for?

Reach out to our Customer Care team to receive information on technical support, assistance for complaints and more.