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How do I retrieve logs from my Secure-UPS XP1K9NN42RCC Power management Unit?

Issue:

How do I retrieve logs from my Secure-UPS XP1K9NN42RCC Power management Unit?

Product Line:

Secure-UPS

Environment:

All models, All Serial Numbers

Cause:

The Secure-UPS XP1K9NN42RCC Power management Unit maintains detailed fault and event logs. This document details how to retrieve them if your unit is not normally monitored via a network connection

Resolution:


How to create a direct connection between a computer and a PMU’s (Power management unit) embedded network management card (NMC)
  1. From the PMU display navigate the the Configuration->Communication->Network menu.
  2. Set the IP Address Mode to Manual.
  3. Set the IP address of the PMU to a non-routable network address.  For our purposes, we will use 192.168.1.2
  4. Set a Subnet mask of 255.255.255.0
  5. Set the default gateway of the NMC as the IP address of the computer. For our purposes we will use 192.168.1.3
  6. The embedded NMC will restart after the configuration change.
  7. Configure a static IP on the computer in the same network. (In a Windows environment this is typically located under control panel > network connections > Local Area Connection.)
  8. Choose properties, scroll down to TCP/IP and choose properties
  9. Click the radio box for "Use the following IP address" and enter the IP information. For our example, enter:
    1. IP: 192.168.1.3
    2. Subnet mask: 255.255.255.0
    3. Default gateway: 192.168.1.2 (which is the IP address of the NMC)
  10. Connect a network cable between the computer and the network port on the PMU.
  11. Launch a web browser and navigate to the NMC page by typing 192.168.1.2 in the address bar.  Log in when prompted.


How to Export Logs (data.txt, event.txt, or config.ini only) via the web interface
A single debug file download, including event.txt and data.txt with many other files can be obtained via the web interface under About->Support->Generate Logs and subsequently Download logs. This same generation/download can be completed via the logzip CLI command and then FTP/SCP to download the single file from the /dbg directory.




To download only specific log files, event.txt or data.txt, follow these steps:
  1. Log into the Network Management Card via a supported web browser.
  2. Navigate to the Logs menu and choose either Data->Log or Event->Log.
  3. Select the floppy disk icon, as shown below and you can export either data.txt or event.txt directly from the web interface to your local computer from the disk icon in their respective menus.



Choose a location on your local computer to save the file with the dialog box that pops up.



Reference links
Link to instructions on how to download the support information from the PMU.  (follow the instructions for the NMC2)
https://www.apc.com/us/en/faqs/FA156131/

Link to some directions for establishing a hardwire connection between the network ports on a laptop and the PMU.
https://www.apc.com/us/en/faqs/FA156366/

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