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PowerChute Network Shutdown VM Prioritization web page displays "vCenter Server is inaccessible. Please verify that the vCenter Server IP/Hostname and logon credentials are correct."

Issue:
PowerChute Network Shutdown VM Prioritization web page displays "vCenter Server is inaccessible. Please verify that the vCenter Server IP/Hostname and logon credentials are correct."

VM prioritization page

Product:
PowerChute Network Shutdown v4.1

Environment:
VMware ESXi

Cause:
Application times out while cataloging VMs.

Solution:

Upgrade to PowerChute Network Shutdown version 4.2
Or
Edit vmprioritization.js file to increase the time out.

If PowerChute has been installed to the default path on Windows OS open C:\Program Files\APC\PowerChute\group1\comp\http\html\scripts\vmprioritization.js with a test editor like Notepad++.

On line 151 there is a timeout value:

"html_data" : {
"ajax" : {
"url" : "/ajaxvmlist",
"data" : {
formtoken : jQuery("#formtoken").val(),
formtokenid : jQuery("#formtokenid").val(),
},
"type" : "POST",
"timeout" : 20000,
"success" : function(data) {
if (data === "99") {
jQuery("#vCenterConnectionError").show();
}

Default value is 20000 change the value to 90000.

After saving the changes to the file you will need to clear the cache in the web browser (so that cached js file is not used).

If PowerChute is install on Linux to the default path to vmprioritization.js will be found in /opt/APC/PowerChute/group1/comp/http/html/scripts/vmprioritization.js

To verify the vCenter username and password in the PowerChute UI go to Communications Settings.

Communications settings page


APC Croatia

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