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Video: Using Network Management Card bootmonitor to recover/upgrade firmware
Issue
Unable to perform or complete a firmware upgrade on the Network Management Card (NMC) via the Firmware Upgrade Wizard and/or FTP.
Product Line
Environment
All Serial numbers.
All Firmware revisions
Cause
Users are unable to upgrade the firmware of the Network Management Card 2 (NMC) due to an interrupted or failed firmware upgrade attempt or because they are not able to communicate with the NMC over the network.
Note: Downgrades are not typically recommended but this method can also be used in certain circumstances.
Note: For users upgrading (or downgrading) their Network Management Card 2 device from v5.X.X to v6.X.X, please review knowledge base FA167693 to understand several important considerations.
Resolution
The BootMonitor is roughly equivalent to the BIOS in a computer system. It offers users the ability to connect to it by using a serial communications cable. Once connected the user can query the BootMonitor for NMC related information, upload firmware files, and reset/format the NMC by issuing relevant commands (a full list of commands is available in Appendix A at the end of this guide).
The following steps highlight how to connect to the NMC BootMonitor (Steps 1 - 3), how to reset the card to the default factory settings (Steps 4 - 5), and how to upload firmware files by using XMODEM (Steps 6 - 10).
Note: Getting access to the BootMonitor is very time-sensitive and may take a few attempts to get it right.
BM>factory_reset
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!! WARNING. Resetting To Factory Defaults Will !!!
!!! Reset All Networking Parameters, User !!!
!!! Configurations And Any Language Pack Installed !!!
!!! This Cannot Be Restored From This Console !!!
!!! !!!
!!! Type: factory_reset_confirm to proceed !!!
!!! !!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
You can monitor the file transfer in the window that opens next. Wait for the file transfer to complete.
After the file transfer is completed successfully the following message appears:
Rhodes BootMonitor
XMODEM Successfully Completed
BM>
Appendix A. BootMonitor command list
Appendix B. Command examples
Example 3: dir command
BM>dir
10/28/2013 00:00:00 <DIR> db
10/28/2013 00:00:00 <DIR> ssl
10/28/2013 00:00:00 <DIR> ssh
10/28/2013 00:00:00 <DIR> logs
10/28/2013 00:00:00 <DIR> sec
10/28/2013 00:00:00 <DIR> dbg
10/28/2013 00:00:00 <DIR> fwl
10/28/2013 00:00:00 <DIR> email
10/28/2013 00:00:08 <DIR> lang
10/28/2013 00:00:08 <DIR> tmp
10/28/2013 00:00:08 <DIR> upsfw
10/28/2013 00:00:14 <DIR> rms
10/28/2013 00:00:14 <DIR> scg
The following video demonstrates firmware management via Bootmonitor:
Unable to perform or complete a firmware upgrade on the Network Management Card (NMC) via the Firmware Upgrade Wizard and/or FTP.
Product Line
- Network Management Card 2 - AP9630/30CH, AP9631/31CH, AP9635/35CH.
- Network Management Card 3 (NMC3) - AP9640, AP9641, AP9544
Environment
All Serial numbers.
All Firmware revisions
Cause
Users are unable to upgrade the firmware of the Network Management Card 2 (NMC) due to an interrupted or failed firmware upgrade attempt or because they are not able to communicate with the NMC over the network.
Note: Downgrades are not typically recommended but this method can also be used in certain circumstances.
Note: For users upgrading (or downgrading) their Network Management Card 2 device from v5.X.X to v6.X.X, please review knowledge base FA167693 to understand several important considerations.
Resolution
The BootMonitor is roughly equivalent to the BIOS in a computer system. It offers users the ability to connect to it by using a serial communications cable. Once connected the user can query the BootMonitor for NMC related information, upload firmware files, and reset/format the NMC by issuing relevant commands (a full list of commands is available in Appendix A at the end of this guide).
The following steps highlight how to connect to the NMC BootMonitor (Steps 1 - 3), how to reset the card to the default factory settings (Steps 4 - 5), and how to upload firmware files by using XMODEM (Steps 6 - 10).
- Connect to the NMC by using the supplied communication cable (940-0299 for AP9630, AP9631, AP9635, SRT UPS embedded NMC or 940-0144 for AP84XX, AP86XX, AP88XX, AP89XX and AP44XX). Connect the RS232 connector to the serial port of the computer and connect the other end of the cable to the NMC Console port.
Note: An USB to serial adapter can also be used if a serial port is not available on the computer.
- In a terminal emulator application (for example Tera Term or Hyperterminal) configure the following port settings:
Bits per second / Baud rate | 57600 |
Data bits | 8 |
Parity | None |
Stop bits | 1 |
Flow control | None |
- Press the Reset button on the NMC (or reseat - unplug/replug the NMC back into the card slot) then immediately and consistently press the Enter key on the keyboard.
Note: Getting access to the BootMonitor is very time-sensitive and may take a few attempts to get it right.
Note: If you are using HyperTerminal set the port settings as described in Step 2 and try to connect to the NMC. If it does not work go to Call -> Disconnect, then go to File -> Properties, click on the Configure button and check the port settings. Reconnect by going to Call -> Call, reseat the NMC or press the Reset button on the NMC then continuously press Enter on the keyboard – you should now see the message displayed below.
After successfully connecting to the NMC BootMonitor the following message appears:
Rhodes BootMonitor
BM>
Looking at the NMC network port the orange Status LED will flash (approximately twice per second).
Rhodes BootMonitor
BM>
Looking at the NMC network port the orange Status LED will flash (approximately twice per second).
- (Optional) Issue the factory_reset command to reset the card to default factory settings.
Note: The factory_reset command is only available with Network Management Cards running BootMonitor v1.0.8 and newer. If you are not sure about the current BootMonitor version installed on the NMC type the sysinfo command to retrieve the version numbers.
BM>factory_reset
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!! WARNING. Resetting To Factory Defaults Will !!!
!!! Reset All Networking Parameters, User !!!
!!! Configurations And Any Language Pack Installed !!!
!!! This Cannot Be Restored From This Console !!!
!!! !!!
!!! Type: factory_reset_confirm to proceed !!!
!!! !!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
- (Optional) Enter the factory_reset_confirm command to confirm the reset.
Note: The factory_reset_confirm command is only available with NMC running BootMonitor v1.0.8 and newer. If you are not sure about the current BootMonitor version installed on the NMC type the sysinfo command to retrieve the version numbers.
BM>factory_reset_confirm
Formatting File System .......
After the reset process completes the BootMonitor prompt appears:
BM>
Formatting File System .......
After the reset process completes the BootMonitor prompt appears:
BM>
- Download and extract the NMC firmware files on the local computer. You can download the latest NMC firmware files from here.
- To update the firmware on the NMC you need to upload the bootmon firmware file, the aos firmware file, and the application module firmware file, in this exact order. To upload the firmware files issue the xmodem command. After issuing the xmodem command you should see C 's appearing after the command indicating the card is ready for the file transfer:
BM>XMODEMCCCCCCCC
- Upload the firmware files to the NMC. (For example in Tera Term go to: File -> Transfer -> XMODEM -> Send…)
- Browse to the location where you extracted the firmware files in Step 6, select the bootmon file (for example apc_hw05_bootmon_108.bin) then click on Open:
You can monitor the file transfer in the window that opens next. Wait for the file transfer to complete.
After the file transfer is completed successfully the following message appears:
Rhodes BootMonitor
XMODEM Successfully Completed
BM>
- After uploading the bootmon file repeat Steps 7 to 9 for the AOS file (for example apc_hw05_aos_640.bin) and application module file (for example apc_hw05_sumx_640.bin).
Note: Always upload the bootmon firmware file first (if a newer version is available it will be present in the files downloaded in Step 6; if the card already has the latest bootmon installed proceed with uploading the AOS firmware file). Next upload the AOS firmware file and lastly the application module firmware file.
SUMX – application module for Smart UPS;
SY – application module for Symmetra single phase;
SY3P – application module for Symmetra 3-Phase;
ATS4G - application module for Rack ATS (AP44XX);
SY3P – application module for Symmetra 3-Phase;
ATS4G - application module for Rack ATS (AP44XX);
Appendix A. BootMonitor command list
Command | Description | BootMonitor version |
---|---|---|
? and help | Displays all available commands. | v1.0.2 and newer |
boot | Allows the NMC to continue the booting process (loading the AOS, then the application module). | v1.0.2 and newer |
reset | Issues a warmstart/network interface restart. This functionality is the same as pressing the Reset button on the NMC. | v1.0.2 and newer |
debug | Puts the card in debug mode - for firmware developer use. | v1.0.2 and newer |
sysinfo | Displays information about the BootMonitor, AOS and application module currently loaded in the flash memory. | v1.0.2 and newer |
mfginfo | Displays basic factory information (MAC address, model number, serial number, date of manufacture). | v1.0.2 and newer |
factory_reset | Initiates a complete reset of the file system (this functionality is equivalent to the format command – more information available under FAQ FA175980 ). | v1.0.8 and newer |
factory_reset_confirm | This command must be entered by the user after the factory_reset command to confirm the reset to factory default settings. | v1.0.8 and newer |
dir | Displays a list of folders available on the NMC. | v1.0.8 and newer |
xmodem | Puts the card in xmodem receive mode allowing the user to transfer the firmware files to the NMC. | v1.0.2 and newer |
Appendix B. Command examples
AP9630 (in SMT750I) | AP9537 (in AP8953) | AP9537SUM (in SRT6KRMXLI) |
---|---|---|
BM>sysinfo Model : AP9630 MAC Address : 00C0B7B71B08 Serial Number: ZA1343024790 CPU Speed : 200 Link Port : 3 Warmstart : NO NMI Count: 0 *********** FLASH MODULE INFORMATION ***************** Boot Monitor : Name : apc_hw05_bootmon_108.bin Version : 108 Cookie : 963200 Build Date : Apr 8 2014 Header Crc : A9D5(PASS) Module Crc : 9897(PASS) AOS : Name : apc_hw05_aos_640.bin Version : 640 Cookie : 963201 Build Date : Dec 18 2015 Header Crc : 5709(PASS) Module Crc : 2D6A(PASS) APP : Name : apc_hw05_sumx_640.bin Version : 640 Cookie : 963201 Build Date : Dec 18 2015 Header Crc : 4F84(PASS) Module Crc : DD2F(PASS) MTO : Not Present LPK : Not Present | BM>sysinfo Model : AP9537 MAC Address : 00C0B7C98918 Serial Number: ZA1031005694 CPU Speed : 200 Link Port : 2 Warmstart : NO NMI Count: 0 *********** FLASH MODULE INFORMATION ***************** Boot Monitor : Name : apc_hw05_bootmon_108.bin Version : 108 Cookie : 963200 Build Date : Apr 8 2014 Header Crc : A9D5(PASS) Module Crc : 9897(PASS) AOS : Name : apc_hw05_aos_640.bin Version : 640 Cookie : 963201 Build Date : Dec 18 2015 Header Crc : 5709(PASS) Module Crc : 2D6A(PASS) APP : Name : apc_hw05_rpdu2g_640.bin Version : 640 Cookie : 963201 Build Date : Jan 21 2016 Header Crc : 4B1A(PASS) Module Crc : 7F49(PASS) MTO : Not Present LPK : Not Present | BM>sysinfo Model : AP9537SUM MAC Address : 00C0B7A1BEED Serial Number: 5A1405T05535 CPU Speed : 200 Link Port : 3 Warmstart: NO NMI Count: 0 *********** FLASH MODULE INFMORMATION ***************** Boot Monitor: Name : apc_hw05_bootmon_102.bin Version : 102 Cookie : 963200 Build Date: Jan 21 2010 Header Crc: F23A(PASS) Module Crc: 1198(PASS) AOS: Name : apc_hw05_aos_620.bin Version : 620 Cookie : 963201 Build Date: Aug 11 2014 Header Crc: 83C0(PASS) Module Crc: 9A96(PASS) APP: Name : apc_hw05_sumx_620.bin Version : 620 Cookie : 963201 Build Date: Aug 11 2014 Header Crc: D83A(PASS) Module Crc: 8ED4(PASS) |
AP9630 (in SMT750I) | AP9537 (in AP8953) | AP9537SUM (in SRT6KRMXLI) |
BM>mfginfo ======== Mfg Information == CRC = PASS MAC Address : 00C0B7B71B08 Model : AP9630 HW Rev : 05 Serial Number: ZA1343024790 Date of Mfg. : 10/28/2013 International: 1 Language : 1 ========================= | BM>mfginfo ======== Mfg Information == CRC = PASS MAC Address : 00C0B7C98918 Model : AP9537 HW Rev : 05 Serial Number: ZA1031005694 Date of Mfg. : 07/27/2010 International: 1 Language : 1 ========================== | BM>mfginfo ======== Mfg Information === CRC = PASS MAC Address : 00C0B7A1BEED Model : AP9537SUM HW Rev : 05 Serial Number: 5A1405T05535 Date of Mfg. : 01/30/2014 International: 1 Language : 1 ========================= |
Example 3: dir command
BM>dir
10/28/2013 00:00:00 <DIR> db
10/28/2013 00:00:00 <DIR> ssl
10/28/2013 00:00:00 <DIR> ssh
10/28/2013 00:00:00 <DIR> logs
10/28/2013 00:00:00 <DIR> sec
10/28/2013 00:00:00 <DIR> dbg
10/28/2013 00:00:00 <DIR> fwl
10/28/2013 00:00:00 <DIR> email
10/28/2013 00:00:08 <DIR> lang
10/28/2013 00:00:08 <DIR> tmp
10/28/2013 00:00:08 <DIR> upsfw
10/28/2013 00:00:14 <DIR> rms
10/28/2013 00:00:14 <DIR> scg
The following video demonstrates firmware management via Bootmonitor:
Released for:APC Hong Kong
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