{}

Search FAQs

{"searchBar":{"inputPlaceholder":"Search by keyword or ask a question","searchBtn":"Search","error":"Please enter a keyword to search"}}

NetBotz 4.x firmware: TLS auto-negotiates to the highest version

Issue:
TLS auto-negotiates to the highest version

Product Line:
NetBotz

Environment:
Botsware version 4.5.2 to 4.7

Cause:
TLS versions 1.0, 1.1, and 1.2 are available on a number of versions of NetBotz firmware. Version TLS 1.2 was added in version 4.5.2 and TLS 1.0 was removed in version 4.6.4

Resolution:
Although version 1.1 is still available, whatever system connects to the NetBotz appliance should auto-negotiate to the highest version of TLS available on both systems. If your browser is capable of 1.2 and your NetBotz appliance is running firmware 4.5.2 or higher, the connection should be made using TLS 1.2.

Did this answer your question?

Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.