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After Network Management Card 2 (NMC2) firmware upgrade, SMTP (email) notifications do not send if custom server settings are in use
Issue
Upon upgrading a Network Management Card 2 (NMC2) device with an originating APC Operating System (AOS) version prior to AOS v6.1.8 upgraded to AOS v6.1.8, AOS v6.2.0 or AOS v6.2.1, custom SMTP (email) server settings in use at the individual recipient level may be reset to different options, causing notifications to potentially fail for one or more recipients using custom settings.
Furthermore, if the originating firmware is AOS v6.1.8, AOS v6.2.0 or AOS v6.2.1, and upgrades to a version after v6.3.0, custom email settings will also be lost.
Lastly, any upgrade with an originating version prior to v6.1.8 to version v6.3.0 or later, custom email settings will be unaffected.
The specific settings that may be reset are:
- Authentication – Values include Enabled or Disabled, for each user
- Use SSL/TLS– Values include Never, If Supported, Always, or Implicit, for each recipient
- Test Result – Values include Not Tested, Passed, DNS Error, or Failed of the last email test, for each user.
- Require CA Root Certificate – Values are Enabled or Disabled, for each user.
- File Name – Name of the SSL certificate to use, for each user.
The settings are reset to the following values:
- Authentication – Disabled
- Authentication/Encryption mode – Never
- Test Result – Not tested
- Require CA Root Certificate – Disabled
- File Name – Empty
Note: "Global" server settings, those located under Configuration->Notification->Email->Server, are unaffected. Only custom server settings at the recipient level are affected.
Product Line
- Network Management Card 2 - AP9630/30CH, AP9631/31CH, AP9635/35CH
Devices with an embedded Network Management Card 2 include (but are not limited to): 2G Metered/Switched Rack PDUs (AP84XX, AP86XX, AP88XX, AP89XX), Certain Audio/Video Network Management Enabled products, Smart-UPS Online (SRT)
Environment
- All serial numbers
- Users on various v6.X.X AOS versions
- Email recpients/notifications in use, using "Custom" server mode
Cause
This is due to a firmware bug that resets the aforementioned fields back to the "first" option in each list of available options. This bug exists in AOS v6.1.8, AOS v6.2.0 and AOS v6.2.1; it affects users who utilize these AOS versions as their originating firmware version or during a firmware upgrade path.
Resolution
This will be addressed in AOS versions after AOS v6.3.0 for any affected applications. Meaning, as long as the original firmware AOS is v6.0.0-v6.1.7 or higher prior to an upgrade and the new/post-upgrade version is post AOS v6.3.0, this issue will not apply.
For an affected user, the aforementioned recipient settings must be re-entered.