{}

Our Brands

{"support":{"yesButton":"yes","noButton":"no","feedback":{"title":"What can we do to improve?"},"submitButton":"Submit","successMessage":"Thank you for your feedback","title":"Was this helpful?","feedbackPercentLabel":"of people found this helpful","captcha":{"error":"Please tick the box"}}}

Search FAQs

{"searchBar":{"inputPlaceholder":"Search by keyword or ask a question","searchBtn":"Search","error":"Please enter a keyword to search"}}

PowerChute Personal Edition 3.1 Check for updates not working

Issue:
PowerChute Personal Edition reports "Could not check for updates"

Image of Error message

Product Line:
PowerChute Personal Edition

Environment:
All Support Windows OS

Cause:
Incorrect response returned.

Solution:
You are currently running the latest version of PowerChute Personal Edition. Please disregard this response. It has no impact on your current installation.

NOTE: We are working on a planned solution for later 2022 and apologize for the inconvenience.

Can't find what you are looking for?

Reach out to our Customer Care team to receive information on technical support, assistance for complaints and more.