{}

Nos marques

{"support":{"yesButton":"Oui","noButton":"Non","feedback":{"title":"Quelles améliorations pouvons-nous apporter ?"},"submitButton":"Soumettre","successMessage":"Merci de nous avoir fait part de vos commentaires.","title":"Cela vous a-t-il été utile ?","feedbackPercentLabel":"personnes ont trouvé cela utile","captcha":{"error":"Veuillez cocher la case appropriée."}}}

Consulter notre FAQ

{"searchBar":{"inputPlaceholder":"Rechercher par mot-clé ou poser une question","searchBtn":"Rechercher","error":"Veuillez saisir un mot-clé pour effectuer une recherche"}}

“Failed dependency error on terminal” during PowerChute Business Edition 8.0.1, 9.0.x, 9.1.x and 9.2.x installation on Red Hat Enterprise Linux 6.x, 7.x and Oracle Linux 7.3

Issue:
The installation requires 32-bit libraries (glibc) to be available on an x64 system.

Product Line:
PowerChute Business Edition  versions 8.0.1, 9.0, 9.0.1, 9.0.2, 9.0.3, 9.1.x, 9.2.0, 9.2.1, 9.0.4

Environment:
Red Hat Enterprise Linux (RHEL) versions 6.x and 7.x
Oracle Linux 7.3

Cause:
32 bit libraries used by PowerChute missing in the x64 Operating System installation.

Solution:
Please follow the steps below to ensure that 32-bit libraries are available on your x64 system:
For RHEL 6.0, 6.1, 6.2, 6.3
1.     Registered Red Hat Network (RHN) users:
Download the Red Hat Package Manager (RPM). For more information see:https://access.redhat.com/knowledge/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Developer_Guide/compilers.html
Download the following packages from RHN:
  • "glibc-x.xx-x.xx.xxx.xxxx.rpm"
  • "nss-softokn-freebl-x.xx.x-x.xxx.xxxx.rpm"

Non-registered users, copy the packages listed above to your desktop from the Packages folder on the CD of one of the following, depending on your RHEL version:
  • RHEL_6.0 X86_64
  • RHEL_6.1 X86_64
  • RHEL_6.2 X86_64
  • RHEL_6.3 X86_64
2.     Navigate to the files’ location and type the command:

yum localinstall --disablerepo=* glibc-x.xx-x.xx.xxx.xxxx.rpm  nss-softokn-freebl-x.xx.x-x.xxx.xxxx.rpm

(Replace x with the relevant package numbering for your RHEL version).
Note:
If you see the following message on the command line:

“Public key for nss-softokn-freebl-x.xx.x-x.x.xxx.xxxx.rpm is not installed”

then, add --nogpgcheck to the command line to disable public key verification (see below):

yum localinstall --nogpgcheck --disablerepo=* glibc-x.xx-x.xx.xxx.xxxx.rpm  nss-softokn-freebl-x.xx.x-x.xxx.xxxx.rpm
3.     When prompted, type “y”.
4.     Install PowerChute versions prior to 9.1 using:
rpm -i pbeagent<version>.rpm
Install PowerChute versions 9.1 and higher using
./install_pbeagent_linux.sh
Red Hat Versionglibc nss-softokn
RHEL 6.0 glibc-2.12-1.7.el6.i686.rpm nss-softokn-freebl-3.12.7-1.1.el6.i686.rpm
RHEL 6.1 glibc-2.12-1.25.el6.i686.rpm nss-softokn-freebl-3.12.9-3.el6.i686.rpm
RHEL 6.2 glibc-2.12-1.47.el6.i686.rpm nss-softokn-freebl-3.12.9-11.el6.i686.rpm
RHEL 6.3 glibc-2.12-1.80.el6.i686.rpm nss-softokn-freebl-3.12.9-11.el6.i686.rpm
Table 1: Red Hat versions 6.0, 6.1, 6.2, 6.3 and associated packages.

For RHEL 6.4, 6.5, 6.6, 6.7, 6.8, and 7.x
1. Registered Red Hat Network (RHN) users, download the following packages from RHN:
  • "glibc-x.xx-x.xx.xxx.xxxx.rpm"
  • "nss-softokn-freebl-x.xx.x-x.xxx.xxxx.rpm"
  • “libstdc++-x.x.x-x.xxx.xxx.rpm”
  • “libgcc-x.x.x-x.xxx.xxxx.rpm”
Non-registered users, copy the packages listed above to your desktop from the Packages folder on the CD of RHEL_6.4 X86_64
3.     Navigate to the files’ location and type the following commands:
yum localinstall --disablerepo=* glibc-x.xx-x.xx.xxx.xxxx.rpm nss-softokn-freebl-x.xx.x-x.xxx.xxxx.rpm
yum localinstall --disablerepo=* libstdc++-x.x.x-x.xxx.xxx.rpm libgcc-x.x.x-x.xxx.xxxx.rpm
(Replace x with the relevant package numbering for your RHEL version).
5.     When prompted, type “y”.

6.     Install PowerChute versions prior to 9.1 using
rpm -i pbeagent<version>.rpm
Install PowerChute versions 9.1 and higher using
./install_pbeagent_linux.sh
RHEL 6.4 Packages
glibcglibc-2.12-1.7.el6.i686.rpm
nss-softoknnss-softokn-freebl-3.12.7-1.1.el6.i686.rpm
libstdc++libstdc++-4.4.7-3.el6.i686.rpm
Libgcclibgcc-4.4.7-3.el6.i686.rpm
Table 2: Red Hat versions 6.4 and associated packages.

RHEL 6.5 Packages
glibcglibc-2.12-1.132.el6.i686.rpm
nss-softoknnss-softokn-freebl-3.14.3-9.el6.i686.rpm
libstdc++libstdc++-4.4.7-4.el6.i686.rpm
Libgcclibgcc-4.4.7-4.el6.i686.rpm
Table 3: Red Hat versions 6.5 and associated packages.

RHEL 6.6 Packages
glibcglibc-2.12-1.149.el6.i686.rpm
nss-softoknnss-softokn-freebl-3.14.3-17.el6.i686.rpm
libstdc++libstdc++-4.4.7-11.el6.i686.rpm
libgcclibgcc-4.4.7-11.el6.i686.rpm
Table 4: Red Hat versions 6.6 and associated packages.
RHEL 6.7 Packages
glibcglibc-2.12-1.166.el6.i686.rpm
nss-softoknnss-softokn-freebl-3.14.3-22.el6_6.i686.rpm
libstdc++libstdc++-4.4.7-16.el6.i686.rpm
libgcclibgcc-4.4.7-16.el6.i686.rpm
Table 5: Red Hat versions 6.7 and associated packages.
RHEL 6.8 Packages
glibcglibc-2.12-1.192.el6.i686.rpm
nss-softoknnss-softokn-freebl-3.14.3-23.el6_6.i686.rpm
libstdc++libstdc++-4.4.7-17.el6.i686.rpm
libgcclibgcc-4.4.7-17.el6.i686.rpm
Table 6: Red Hat versions 6.8 and associated packages.
RHEL 6.9 Packages
glibcglibc-2.12-1.209.el6.i686.rpm
nss-softoknnss-softokn-freebl-3.14.3-23.el6_8.i686.rpm
libstdc++libstdc++-4.4.7-18.el6.i686.rpm
libgcclibgcc-4.4.7-18.el6.i686.rpm
Table 7: Red Hat versions 6.9 and associated packages.
RHEL 6.10 Packages
glibcglibc-2.12-1.212.el6.i686.rpm
nss-softoknnss-softokn-freebl-3.14.3-23.3.el6_8.i686.rpm
libstdc++libstdc++-4.4.7-23.el6.i686.rpm
libgcclibgcc-4.4.7-23.el6.i686.rpm
Table 8: Red Hat versions 6.10 and associated packages.
RHEL 7.0 Packages
glibcglibc-2.17-55.el7.i686.rpm
nss-softoknnss-softokn-freebl-3.15.4-2.el7.i686.rpm
libstdc++libstdc++-4.8.2-16.el7.i686.rpm
Libgcclibgcc-4.8.2-16.el7.i686.rpm
Table 9: Red Hat versions 7.0 and associated packages.

RHEL 7.1 Packages
glibcglibc-2.17-78.el7.i686.rpm
nss-softoknnss-softokn-freebl-3.16.2.3-9.el7.i686.rpm
libstdc++libstdc++4.8.3-9.el7.i686.rpm
Libgcclibgcc-4.8.3-9.el7.i686.rpm
Table 10: Red Hat versions 7.1 and associated packages.
RHEL 7.2 Packages
glibcglibc-2.17-105.el7.i686.rpm
nss-softoknnss-softokn-freebl-3.16.2.3-13.el7.i686.rpm
libstdc++libstdc++4.8.5-4.el7.i686.rpm
Libgcclibgcc-4.8.5-4.el7.i686.rpm
Table 11: Red Hat versions 7.2 and associated packages.
RHEL 7.3 & Oracle 7.3
Packages
glibcglibc-2.17-157.el7.i686.rpm
nss-softoknnss-softokn-freebl-3.16.2.3-14.4.el7.i686.rpm
libstdc++libstdc++4.8.5-11.el7.i686.rpm
Libgcclibgcc-4.8.5-11.el7.i686.rpm
Table 12: Red Hat versions 7.3, & Oracle Linux 7.3 and associated packages.
RHEL 7.4 Packages
glibcglibc-2.17-196.el7.i686.rpm
nss-softoknnss-softokn-freebl-3.28.3-6.el7.i686.rpm
libstdc++libstdc++4.8.5-16.el7.i686.rpm
Libgcclibgcc-4.8.5-16.el7.i686.rpm
Table 13: Red Hat versions 7.4 and associated packages.
RHEL 7.5 Packages
glibcglibc-2.17-222.el7.i686.rpm
nss-softoknnss-softokn-freebl-3.34.0-2.el7.i686.rpm
libstdc++libstdc++4.8.5-28.el7.i686.rpm
Libgcclibgcc-4.8.5-28.el7.i686.rpm
Table 14: Red Hat versions 7.5 and associated packages.
RHEL 7.6 Packages
glibcglibc-2.17-260.el7.i686.rpm
nss-softoknnss-softokn-freebl-3.36.0-5.el7_5.i686.rpm
libstdc++libstdc++-4.8.5-36.el7.i686.rpm
Libgcclibgcc-4.8.5-36.el7.i686.rpm
Table 15: Red Hat versions 7.6 and associated packages.
RHEL 7.7 Packages
glibcglibc-2.17-292.el7.i686.rpm
nss-softoknnss-softokn-freebl-3.44.0-5.el7.i686.rpm
libstdc++libstdc++-4.8.5-39.el7.i686.rpm
Libgcclibgcc-4.8.5-39.el7.i686.rpm
Table 16: Red Hat versions 7.7 and associated packages.
En savoir plus
Catégorie :
Software
En savoir plus
Catégorie :
Software

Vous ne trouvez pas ce que vous recherchez ?

Contactez notre service client local si vous avez des questions ou si vous avez besoin de plus de détails ou d'une assistance technique.