{}

Our Brands

Search FAQs

PowerChute Network Shutdown version 4.1 web interface is not accessible after installation on Solaris 10 and 11

Issue:
The web interface is inaccessible after installing PowerChute Network Shutdown on Solaris 10 or 11.

Product Line:
PowerChute Network Shutdown version 4.1

Environment:
Solaris 10 and 11

Cause:
When reviewing error.log, there is an entry FATAL Timer-2 com.apcc.m11.components.WebServer.WebServerThread - Start server exception:
java. lang.IllegalStateException: Insufficient max threads in ThreadPool: max=200 < needed=XXX (where XXX is greater than 200)
NOTE: When PowerChute is installed to the default path, error.log will be found in /opt/APC/PowerChute/group1

Resolution:

Uninstall PowerChute Network Shutdown version 4.1 and install version 4.2 or 4.3.

OR
1 - Stop the PowerChute daemon. The command is /etc/rc2.d/S99PowerChute stop
2 - Once the service has been stopped, copy the attached updated pcns.jar file to /opt/APC/PowerChute/group1/comp folder if PowerChute has been installed to the default path.
NOTE: We suggest keeping a copy of the old pcns.jar as a backup.
3 - Open powerchute.sh with a text editor and change the line ulimit -n 1024 to ulimit -n unlimited. The file powerchute.sh, will be found in /opt/APC/PowerChute/group1 if PowerChute has been installed to the default path.
NOTE: We suggest keeping a copy of PowerChute.sh as a backup.
4 - Start the PowerChute daemon. The command is /etc/rc2.d/S99PowerChute start



APC Canada

Attachment(s)

pcns.jarpcns.jar [1.66 MB]
Explore more
Explore more
Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.