{"support":{"yesButton":"yes","noButton":"no","feedback":{"title":"What can we do to improve?"},"submitButton":"Submit","successMessage":"Thank you for your feedback","title":"Did this answer your question?","feedbackPercentLabel":"of people found this helpful","captcha":{"error":"Please tick the box"}}}
Search FAQs
{"searchBar":{"inputPlaceholder":"Search by keyword or ask a question","searchBtn":"Search","error":"Please enter a keyword to search"}}
Video: Battery Replacement for Back-UPS XS & RS LCD units.
Issue:
UPS indicates battery requires replacement.
Product Line:
Environment:
All Serial Numbers
Cause:
Failed selftest resulting in a need for battery replacement. UPS batteries require periodic replacement based on usage and operating environment.
Resolution:
The following video will provide details to removing and reconnecting the internal battery for the Back-UPS XS & RS LCD family of units.
UPS indicates battery requires replacement.
Product Line:
- BR1500LCD
- BX1500LCD
- BR1300LCD
- BX1300LCD
- BN1250LCD
Environment:
All Serial Numbers
Cause:
Failed selftest resulting in a need for battery replacement. UPS batteries require periodic replacement based on usage and operating environment.
Resolution:
The following video will provide details to removing and reconnecting the internal battery for the Back-UPS XS & RS LCD family of units.
Can't find what you are looking for?
Reach out to our Customer Care team to receive information on technical support, assistance for complaints and more.