Browse FAQs

Error while running config.sh file after upgrading Java version of PCBE 10.0 and 10.0.1

Published date: 19 November 2020

Issue:
In Linux based operating systems while running config.sh file after upgrading JDK version to latest JDK the config.sh file throws an Error 206

Product Line:
PowerChute Business Edition v10.0 and 10.0.1 (PCBE).


Environment:
Linux Based Operating systems with PCBE v10.0 and 10.0.1 installed.

Cause:
Linux Based Operating systems with PCBE v10.0 and 10.0.1 installed. Re-running the config.sh file after upgrading PCBE java version to latest java, throws an error - 206 which is based on the current java path of PCBE.


Resolution:

Please follow below steps after JDK version is upgraded to latest.


1. Open Terminal and navigate to /opt/APC/PowerChuteBusinessEdition/Agent/config.sh and Edit the config.sh file as follows.       
           a. Open config.sh file and go to line number 206.
           b. Update the old JDK path with new JDK path and save the file.

Example:
Old JDK path is mentioned as /opt/APC/PowerchuteBusinessEdition/Agent/../jre/bin/java
New JDK path (/opt/APC/PowerChuteBusinessEdition/jdk-x.x.x/jre/bin/java).

  2. Try to run config.sh file from the terminal as shown below and make the necessary configuration changes.
  • sh /opt/APC/PowerChuteBusinessEdition/Agent/config.sh

Was this helpful?

What can we do to improve the information ?

Can't find what you are looking for?

Reach out to our customer care team to receive information on technical support, assistance for complaints and more.