Technical FAQs

Ask a Question

Unable to install PowerChute Network Shutdown version 3.0.1 with bundled Java (JRE 1.6.0_31) on Oracle VM 3.1.1 Server

Issue:
PowerChute Network Shutdown version 3.0.1 fails to install with bundled Java (JRE 1.6.0_31) on Oracle VM 3.1.1 Server. Throws an error message " bad ELF interpreter. Please install the OS compatible dependent packages of glibc and nss-softokn file”.

Product Line:
PowerChute Network Shutdown version 3.0.1

Environment:
Oracle VM 3.1.1 Server

Cause:
PowerChute Network Shutdown 3.0.1 installation with bundled java requires 32-bit glibc packages which are not available on Oracle VM 3.1.1 Server 64 bit OS.

Solution:
 In order to proceed with PowerChute installation with bundled java , follow any of the solutions below.

1. Install PowerChute 3.0.1 using latest java. This doesn’t require installation of any glibc packages (Note: this is an alternate solution)

2. The required glibc packages can be downloaded from ORACLE website, install them manually before proceeding with PowerChute 3.0.1 installation.
Here is the link  http://public-yum.oracle.com/repo/OracleVM/OVM3/latest/x86_64/
Steps:
i. Download "glibc-2.5-49.el5_5.4.i686.rpm" from the above link and copy to Oracle VM server 3.1.1
ii. Install using command #> rpm -i glibc-2.5-49.el5_5.4.i686.rpm
And you are ready to install PowerChute 3.0.1 with bundled java.

3. Oracle has released a Oracle VM 3.1.1 patch OS which includes the required 32 bit glibc packages. User can migrate the OS to Oracle VM 3.1.1 ISO Patch update 612 OS. Here is the link. http://www.oracle.com/technetwork/server-storage/vm/downloads/index.html  
You need to have additional privileges to download this package.

4. Proceed with Oracle VM 3.2.2 OS which also has the required 32 bit glibc packages in it. Here is the link. https://edelivery.oracle.com/linux

Was this helpful?
What can we do to improve the information ?