Technical FAQs

Ask a Question

AP9620 Legacy Communications Card (LCC) Firmware Update Instructions

 

Issue

AP9620 Legacy Communications Card (LCC) Firmware Update Instructions


Product Line

  • Device UPS Management
    • AP9620 Legacy Communications Card

Environment
 
  • All serial numbers
  • All firmware versions

Cause

The AP9620 Legacy Communications Card (LCC) originally shipped with version v1.6, and subsequently shipped with versions v2.2 or v3.0. An update has been released for v3.1. Attached to this article is a PDF containing instructions, firmware release notes, and the LCC firmware update file(s).


Resolution

Requirements for performing this procedure are:
 
  • 940-0024 or 940-1524 APC Serial cable
  • Computer with serial port available
  • Local access to the LCC's DB9 port
  • A terminal emulation program such as HyperTerminal or Tera Term that is capable of an XMODEM file transfer
  • The instructions and firmware file attached to this knowledgebase



For any users looking to upgrade their LCC, please send them the attached zip file that contains the instructions and firmware file. After the upgrade is performed, you can verify the LCC's firmware version from the About menu on the UPS's LCD screen (if available). Alternatively, with version 3.0 or later, the firmware versions will be diplayed if you hit "enter" in the terminal emulation program after the firmware update is complete (and the baud rate is restored to 2400 baud)



Also available for review, if needed, is the UPS/LCC Compatibility Matrix.

 

Was this helpful?
What can we do to improve the information ?