Technical FAQs

Ask a Question

PowerChute Business Edition no longer works using JRE 8 Update 91 or greater.

Issue:
The PowerChute Business Edition versions listed below are unable to support JRE 8 Update 91 or above due to JRE security changes made which impact how PowerChute Business Edition functions.

Product line:
PowerChute Business Edition versions 9.0.3, 9.1.1, 9.2.0

Environment:
Windows x64, Windows x86, Linux.
See attached compatibility list

Cause:
The latest release of JRE 8 Update 91 (and greater) contains a security update which breaks PowerChute Business Edition functionality.

Solution:
Upgrade to or install the attached PowerChute Business Edition upgrade (v9.2.1) & (9.0.4)which is shipped with JRE 8 Update 102. By upgrading to v9.2.1 or 9.0.4, the functional issues caused by the JRE 8 Update 91 changes are fixed. This upgrade is available for supported Windows and Linux operating systems.

Note: Once you have upgraded to v9.2.1, or 9.0.4 the software will be fully functional. However, if you then decide to upgrade the JRE to a later version than Update 102 using the JRE Configuration Tool, then the additional manual changes specified in Answer ID #FA264735, FA264736 & FA253763 are still required for communications between the PowerChute Agent and PowerChute Console. 

If your UPS is a SMT, SMX, SURTD, SRT, SMC PowerChute Agent 9.2.1 will be installed.
If your UPS is a SU, SC, SUA, SURT, SURTA, Matrix PowerChute Agent 9.0.4 will be installed.

Upgrade to or download v9.2.1 / 9.0.4 from:
5 Node for Windows
5 Node for Linux
Was this helpful?
What can we do to improve the information ?